Services degraded performance

Incident Report for Nayax

Resolved

This incident appears to have been resolved form Mastercard side. Monitoring will continue to insure stability.
Posted Aug 15, 2026 - 08:55 IDT

Identified

We are working to resolve an issue of degraded performance. We are seeing a Global issue related to Mastercard. Please consider Using Other Payment Service.
Posted Aug 15, 2026 - 08:48 IDT
This incident affected: Africa & Middle East (Transactions), Asia-Pacific (Transactions), Germany (Transactions), Rest of Europe (Transactions), and North America (Transactions).