Billing provider transaction issue - RB Aval

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Apr 26, 2025 - 12:43 IDT

Monitoring

RBI/ RBA are working on a resolution, and we will update you with further information as it becomes available.
Posted Apr 26, 2025 - 08:48 IDT

Investigating

We are in touch with RB Aval / RBI about a service outage with its billing gateway, which appears to be affecting transactions. They are working on a resolution, and we will update you with further information as it becomes available.
Posted Apr 26, 2025 - 08:30 IDT