Billing provider transaction issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 18:56 IDT

Update

We are continuing to investigate this issue.
Posted Apr 17, 2025 - 17:07 IDT

Investigating

We are in touch with Billing Provider about a service outage with its billing gateway, which appears to be affecting all transactions. They are working on a resolution, and we will update you with further information as it becomes available.
Posted Apr 17, 2025 - 17:06 IDT
This incident affected: Africa & Middle East (Transactions).