EV Service issue in IL

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Dec 14, 2025 - 16:18 IST

Identified

We are working to get our solution back up and running in 30 minutes, following a service issue.
Posted Dec 14, 2025 - 12:02 IST
This incident affected: Israel (Transactions).