Testing for NOC, please ignore.

Incident Report for Nayax

Resolved

Incident has been resolved.
Posted Jul 30, 2025 - 09:55 IDT

Investigating

test only
Posted Jul 30, 2025 - 09:47 IDT