PEP Billing provider transaction issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 16:02 IDT

Identified

Our partner has a located the issue and is fixing the problem. We are working to re-establishing our complete service as soon as possible.
Posted Jul 29, 2025 - 12:05 IDT

Investigating

We are in touch with PeP (Poland) about a service outage with its billing gateway, which appears to be affecting all transactions. They are working on a resolution, and we will update you with further information as it becomes available.
Posted Jul 29, 2025 - 10:50 IDT
This incident affected: Rest of Europe (Transactions).