Billing Provider Banorte- Decline in Transactions.

Incident Report for Nayax

Resolved

This incident has been resolved, thank you for your patience.
Posted Apr 25, 2025 - 14:47 IDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2025 - 14:09 IDT

Update

We are seeing improvement as the decline rate decreases, we will continue to monitor and confirm once resolved.
Posted Apr 25, 2025 - 14:08 IDT

Investigating

We are currently seeing around 40% decline in transactions with the Billing Provider Banorte, we are in contact with the provider and working to get this resolved as soon as possible. Updates to follow.
Posted Apr 25, 2025 - 13:28 IDT
This incident affected: North America (Transactions).