Billing provider Travelbuy transaction issue

Incident Report for Nayax

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 18:43 IDT

Investigating

We are in touch with Travelbuy regarding transactions being declined and we will update you with further information as it becomes available.
Posted Apr 22, 2025 - 17:39 IDT
This incident affected: Africa & Middle East (Transactions).